PDA

View Full Version : Can't get 'g' computer onto 'b' network



TonyDi
07-14-2007, 04:48 PM
One of my neighbors was here today and we tried to connect to my wireless network. Right now I'm using an old D-Link which only have 802.11b. His new MacBook has 802.11g which should be backward compatible. Could not establish a connection between the D-Link and the MacBook.

I then connected my ActionTek that came with FIOS. The ActionTek is 802.11g and my neighbor's MacBook connected immediately.

I searched the Preferences in the Mac and didn't find any setting like 'don't connect to 'b' network.

Any ideas why the new MacBook wouldn't connect to my old router?

Dan18960
11-14-2007, 06:25 AM
Tony,

Did you ever resolve this?

:cool:

TonyDi
11-14-2007, 08:27 AM
No - I heard a rumor that it was a problem with some of the new MacBooks. Someone in one of my Mac groups reported there are several postings along the same lines in Apple's MacBook discussion forum. There was a suggestion to update the firmware on the router.

Note: The D-Link router that I was unable to connect to was pretty old; it was an 802.11 'b' only. So maybe the firmware update suggestion would work.

JohnWill
11-14-2007, 09:56 AM
You should check the Actiontec MI424WR wireless configuration. You may be configured for 802.11g only, you want 802.11b/g compatibility. Also, the encryption may be set at something that the old machine can't deal with, say WPA or WPA2.

TonyDi
11-14-2007, 10:21 AM
The MacBook connected fine with the ActionTec, which is configured for mixed environment. The problem was that it wouldn't connect to the older D-Link, which is 'b' only as it was manufactured before 'g' came out. I don't use encryption.

JohnWill
11-14-2007, 11:06 AM
OK, got it backwards. :)

On the D-Link, I'd suggest configuring for plain 802.11b, and remove any "turbo" options. I know that my old D-Link DI-614+ had several options that would make it difficult or impossible to connect to some devices.